Upgrading Triaster Server to 16.2

 This article is suitable for an IT Adminstrator

Ref: 201603231139 AR
Last Edited: May 25th, 2016

The following instructions apply if you are upgrading FROM 15.1 or 15.3 TO 16.2.

If you are upgrading from an earlier version, please contact Triaster Customer Services first. This is because each Triaster Process Library has a customised homepage design and specific alerts and approvals requirements, the configuration of the new menu editor and alerts and approvals functionality will need to be Library specific. 


It is strongly recommended that this installation is tested on a test server prior to the upgrade of your Live Library.
If the Triaster solution is installed on a virtual server then please take a snapshot before following the instructions below. This will enable you to rollback if required.

Prior to upgrading you will need:   þ
The publication user account and password (You will need to log in as this user to complete the upgrade).  
The current installation path for the Triaster Server and Process Navigator. This is stored on your client site. If you have any difficulties with this, please contact Triaster Customer Services.      
To ensure that your server meets the Triaster minimum system requirements, which you can find by clicking here. A minimum requirements check is also built in to the Triaster Server installer and will alert you if your system does not meet the minimum requirements.  
The operating system of your server. 
To notify customer.services@triaster.co.uk of your planned upgrade date, so we can ensure we are on hand to assist if required, and advise if you require a bespoke upgrade plan.  
To take a back up of the 'TriasterServer2011' folder. ( Please note that this may take a while, depending on how many maps you have). This folder is generally found within C:\Triaster, but may be a different location such as E:\Triaster, depending the current installation path. Please contact Triaster Support if you are unsure about what to do.  


Software Upgrade Process

1. Log on to the Server as the publication user account.

2. Check whether 32 or 64 bit Visio is installed. To do this open Visio and follow the instructions below depending on which version of Visio is installed.
    a. Visio 2007: Always 32-bit. 
    b. Visio 2010: Go to File -> Help. On the right hand side under About Microsoft Visio there will be a version number. The bitness (32-bit or 64-bit) is specified with this number
    c. Visio 2013: Go to File -> Account. Click About Visio (question mark icon). The bitness (32-bit or 64-bit) is shown at the top of the About Visio box.

3. Download the new software versions of both Triaster Server and Process Navigator from the software downloads page (http://knowledgebase.triaster.co.uk/Home/software-downloads). The Process Navigator version downloaded must correspond to the bitness of Visio (see step 2).

4. Install Process Navigator by running ProcessNavigator.msi within the Process Navigator zip file. Ensure the install path displayed matches that of the current installation path.

5. 6. Extract the Triaster Server zip file to a location on the server (such as the Desktop). Run the newly downloaded version by double-clicking Setup.exe. If you are running this for the first time, you will need to enter the Publication user details as shown in the image below. 



If all requirements have been met and the screen below is shown, the installation can be run by clicking the “Start Installation” button. Click OK to any prompts. A message will be shown when the installation has completed. If the message below is not shown, please see the trouble-shooting steps below.



6. Run the Post Install utility by navigating to the TriasterServer2011\Services folder and right-clicking 'Run as administrator' on the file TriasterServerPostInstall.exe. IMPORTANT NOTE: this should only be done if you are using the default settings of running the Triaster Server software under the TriasterAppPool application pool and Default Web Site in IIS. If you are not using these settings or are unsure, please contact Triaster Support (support@triaster.co.uk) for further advice.

Trouble-Shooting

1.     Minimum requirements not met. If these have not been met, you may experience performance problems with your Process Library. You are advised to contact your IT in the first instance. Details of how well the current system meets minimum requirements can be viewed in the View Minimum Requirements Report.



2.     User details not entered.  You will need to click on the Edit Details tabs and enter the Publication User account details. If you do not wish to store these details, they will need to be re-entered on each installation.

For further advice please contact Triaster Support

 

Displaying Key Features and Minimum Requirement Compliance

1.    The Triaster Server Upgrade Utility can be run at any time (without needing to install the software) in order to show both if the minimum requirements have been met as well as what key features (Auto Copy of Maps, Mobile Library, Newspage, Menu Editor and Search Type) have been installed.

2.    In additional to displaying the information onscreen, a text file is created within the installation folder which contains the same information. This can be then be emailed to Triaster if required.








Need further help? Contact the Triaster Support team by e-mailing support@triaster.co.uk or by calling us on + 44 (0)870 402 1234.
 
Do you have any feedback or suggestions that you would like to share with Triaster? We would love to hear from you! Please e-mail feedback@triaster.co.uk