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System IO Error when cloning

 This article is suitable for a Library Administrator

Ref: 200911241334 
Last Edited: September 28th 2011 
 
Symptoms:
Cloning failing when path for published HTML is different on publication server and web server. When attempting to clone a site or library, the Improvement Workbench Server will report an error (via email) such as the one below. This error will also be logged in the Windows Event Log.
This problem occurs when the Improvement Workbench Server and Browser Toolkit are on different machines and the path to the published HTML is different. For example, on the web server machine it might be C:\Triaster\ProcessLibraries\ProcessLibrary\Live\html and on the publication server machine it might be \\myserver\ProcessLibraries\ProcessLibrary\Live\html.
 
System.IO.DirectoryNotFoundException: Could not find a part of the path 'c:\triaster\proce\ProcessLibrary\Sandpit'.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.Directory.InternalGetFileDirectoryNames(String path, String userPathOriginal, String searchPattern, Boolean includeFiles, Boolean includeDirs, SearchOption searchOption)
   at System.IO.DirectoryInfo.GetDirectories(String searchPattern, SearchOption searchOption)
   at System.IO.DirectoryInfo.GetDirectories()
   at ImprovementWorkbenchServer.clsMain.CopyDirs(DirectoryInfo objDirInfo, String strTargetPath)
   at ImprovementWorkbenchServer.clsMain.UpdateWebServerFilesForSite(String strLibrary, String strOldStageName, String strNewStageName, String strRootPath)
   at ImprovementWorkbenchServer.clsMain.UpdateFilesForCloneStage(String strLibrary, String strOldStage, String strNewStage, String strConfigRoot, String strContainer)
   at ImprovementWorkbenchServer.clsMain.ProcessTask(FileInfo objTask, String strQueueFolder)

 
Cause:
This is a problem with Improvement Workbench Server version 9.1.0
  
Solution:
The issue is fixed by upgrading to Browser Toolkit version 9.1.1 and Improvement Workbench Server version 9.1.1
 
Applies to:
  • Improvement Workbench Server version 9.1.0

 

Need further help? Contact the Triaster Support team by e-mailing support@triaster.co.uk or by calling us on +44 (0)870 402 1234.
 
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