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Server Error in '/Triaster Browser Toolkit/Admin' Application

Ref: 2633319 (201011031411) 
Last Edited: December 22nd, 2010
 
Development Ref: 78
 
 
Symptoms:
When using the web-based Admin tool to, for example, update lists, an error is reported when performing an action such as a button-click.
Server Error in '/Triaster Browser Toolkit/Admin' Application.
 
The description and details will probably depend on whether the website is being used directly at the hosting server or from a remote client. When viewing from a remote client, a general application error is usually reported. When viewing on the hosting server, the error message will contain details of an "unhandled exception".
 
The issue can be produced as follows:
  1. Remove the relevant permissions (such as ASPNET) needed for the web browser from the Ownership folder (eg \ProcessLibrary\Live\Tools\Ownership).
  2. Edit the Ownership filter content and click Save.
  3. The unhandled exception (described above) will be shown.

 

Cause:
The unhandled exception is usually produced because the system does not have access to the necessary file.  
 
Solution:
In the first instance, permissions on the relevant folders (such as ProcessLibraries should be checked)
The error will be handled in a more user-friendly way, consistent with the rest of the Browser Toolkit, in a future release of the software. 
 
Applies to:
  • Triaster Browser Toolkit
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