Publishing to HTML

Multi-Map > Export Wizard > HTML Wizard

Remember to set your Multi-Map Root  before publishing to HTML.

The language used by many intranet pages is called Hypertext Mark-up Language (HTML). Process Navigator, in conjunction with Visio, contains a powerful HTML generator to enable you to publish the entire Multi-Map to HTML format.

Publishing the enterprise process map is a fundamental part of the feedback loop required to improve quality. The Corporate Intranet is a perfect vehicle for publishing process maps. Furthermore, the hyperlinks contained in the maps continue to work, so all the supporting documentation, video and audio files, spreadsheets etc. that you linked to from the maps are also viewable. Web format is read only, so your maps are safe from inadvertent changes and, as a final advantage, browser software is generally free!

When an individual can see their process maps on the intranet and can see everybody else’s process maps on the intranet, it encourages several positive things:

  • Pride in their work.
  • Pride in the process map that represents their work.
  • Curiosity in the upstream and downstream flows of which their Deliverables are a part.
  • A natural leaning towards making the map more accurate.
  • A natural desire to improve working practices.
  • Intranet Set-up
At the simplest level, intranets are merely a set of files stored on a server that are accessible to all users within a business, and Internet browsers such as Internet Explorer display these files in user friendly form.

Publishing to an intranet is an occasional process, perhaps monthly in the early stages of process discovery, and then quarterly as continual process improvement feeds through to changes in the process maps.

Absolute and Relative Hyperlinks

It is important to be aware how relative and absolute hyperlinks work in the HTML versions of your process maps.

Absolute hyperlinks always link to the same place, irrespective of where they link from; relative links on the other hand change their target link if the source document moves.

The significance of this becomes apparent when exporting to HTML maps that link to external documents other than Process Navigator maps. In the HTML domain, whereas the absolute hyperlinks will still link to the same files, the relative ones may not. Indeed, the relative hyperlinks will only link to the same place when the HTMLROOT (the location of your HTML files) and the Multi-Map Root (the location of your .vdx files) are in the same relative location.

Below are listed four scenarios to help explain the use of relative or absolute hyperlinks.

Scenario 1

 
Absolute
 
Multi-Map Root M:\Process Library\
Linked Documents R:\Process Library Documents\

HTML

P:\Intranet\Process Library\
 
In this first scenario, you will notice that the Multi-Map Root, the linked documents and the target root of the HTML export are in three different locations. Assuming that you do not want to take copies of the linked documents and put them in the same location as the HTML target root, the links will need to be absolute.
 
However, if the R:\ is subsequently remapped to Q:\ after the HTML export, the absolute links will not be valid.  Therefore, you will need to use Process Navigator’s Replace Hyperlinks feature
 
Scenario 2
 
Absolute and/or Relative
 
 Multi-Map Root  M:\Process Library\
 Linked Documents  M:\ProcessLibrary Documents\
 HTML  M:\Process Library HTML\
 
This scenario can use either absolute or relative hyperlinks. Relative hyperlinks can be used because Linked Documents is in the same relative location to Multi-Map Root as it is to HTML.

The benefits of using relative hyperlinks is that if, for example, you intend to e-mail a set of process maps with hyperlinks to someone outside of your office, they will be able to view the maps because the links are relative.  If the links were absolute, the person would not be able to view the hyperlinks because the maps would be looking for drive M:\ (as per the above example) which they will not have.

Absolute hyperlinks would have to be used in this scenario if, for example, the HTML location changes to another drive.

Scenario 3

Absolute
 
Multi-Map Root M:\Process Library\
Linked Documents
M:\Process Library Documents\
T:\ Process Policies\
T:\Enterprise Procedures\
HTML M:\Process Library HTML\
 
In this scenario, you will notice that the linked documents are located in three separate folders.  An absolute hyperlink will be required for each.

Scenario 4

 
Relative
 
Multi-Map Root  M:\Process Library\
Linked Documents  R:\Process Library Documents\
Copies of linked Documents  P:\Intranet\Process Library\
HTML  P:\Intranet\Process Library\
 
This last scenario shows that copies of Linked Documents are placed in the same location as the HTML server.  Relative hyperlinks, therefore, can be used.

To understand the implications of this, you should set up a test before undertaking widespread process mapping. Make sure you link to a wide variety of objects in the test, external documents, other Visio maps, maps on different drives etc. When you export the set of test files to HTML, test that each of the links works in the way you anticipate. Then load the HTML files up onto the intranet or Internet to ensure that all links work as expected.

Publish to HTML Wizard Step-by-Step

Before publishing to HTML, you should ensure you have resolved as many Deliverable mismatches as you can. You should also Refresh Off-Page Connectors.

Please ensure that all open maps have been saved first.

To do this, click Save from the File menu in Microsoft Visio. Failing to do this may result in hyperlinks not being correctly set.

Step One

Select Multi-Map > Export > HTML Wizard. Click Next

Step Two

The second screen of the Wizard enables you to specify the target location for the HTML files and several other settings.

Target root
Select the folder where the exported HTML files will be stored.
 
Type the name and path, or browse to find the target folder.
 
Export modified files only
 
If this option is checked then only those files which have recently been modified will be processed.
Backup existing files
 
There is an automatic versioning facility built into Process Navigator which relies on changing the name of the target folder prior to saving. The first time you publish to HTML, the target folder is created and the folder settings are recorded. Each subsequent time you publish to HTML, the target folder is renamed to <date> backup <x>, where x is a sequential number that increases for each save made that day and is moved to the backup root folder. The new HTML publication is then written into the target folder. This ensures all existing links to the process map remain valid, but old versions of the map are also properly archived.

NOTE: If existing files are not backed up, they will be overwritten.

It is recommended that only Process Navigator creates files in the target folder. If other applications create files in this area, they will be moved every time the map is published.

Click Backup existing file if you wish to take a backup copy. Click Next.

Step Three

 

The third screen of the Publish to HTML Wizard enables you to specify optional additional Outputs to the process map itself. These are:

  • Text or HTML files to be included in the position of header or footer text. This is a useful technique for automatically adding a common HTML menu or script into every page of the process map. These need to be created prior to export to HTML.
  • The option to export meta data adds specific <META> fields into the HTML containing the text and property values (optional) of each Process Navigator symbol used in the drawing. This is useful if search engines need to index the HTML files.
  • The option to convert Hyperlink Circle hyperlinks to HTML should be checked unless you intend to use Hyperlink Circles to point to the actual Visio files themselves rather than their HTML equivalents.
  • Visio 2003/2007 users have the option to view the hyperlink within the ToolTip when viewing the HTML as they would using Visio 2002. Please see below for more detail about the differences between viewing hyperlinks in HTML when using Visio 2002 versus Visio 2003.
 
 
 Hyperlink Option VIEWED IN TOOLTIP USING VISIO 2002 VIEWED IN TOOLTIP USING VISIO 2003/2007 VIEWED IN TOOLTIP USING VISIO 2003/2007 AND USING VISIO 2002 MOUSE OVER OPTION SELECTED
Hyperlink with sub-address and hyperlink description inserted on a shape with custom properties
Hyperlink description
Shape Name

Ctrl + Click to view details

Click to follow hyperlink

Hyperlink description

Ctrl + Click to view details

Click to follow hyperlink

Hyperlink with sub-address inserted on a shape with custom properties Hyperlink address#hyperlink subaddress Shape Name

Ctrl + Click to view details

Click to follow hyperlink

Hyperlink address#hyperlink sub address

Ctrl + Click to view details

Click to follow hyperlink

 Hyperlink only inserted on a shape with custom properties Hyperlink address Shape Name

Ctrl + Click to view details

Click to follow hyperlink

Hyperlink address

Ctrl + Click to view details

Click to follow hyperlink

No hyperlink inserted on shape that has custom properties
 N/A Shape Name

Ctrl + Click to view details

Shape Name

Ctrl + Click to view details

Shape without hyperlink or custom properties  N/A  N/A  N/A
 
The ‘Use description where available’ option enables users to have the text within the description field of a shape to appear in the ToolTip. If this option is selected, this will override the Visio 2002 mouse over option.

Click Finish when you have completed this step

Table of Contents of Published Maps

 
Once the maps have been published, Process Navigator will create a Table of Contents report based on the Activities in the maps. This can be viewed by clicking the Report Viewer Icon. A copy of this report will be saved in the reports location (Tools > Options, select the Reports tab).

Published Map Viewer

 
Visio will open to publish each of the maps to HTML.  When complete, Visio will close down and the Published Map Viewer will show as below. From this point, you can drill down on the Activities to the lower level maps and all hyperlinks within the maps are maintained.

NOTE: In this particular report, Table of Contents.xslt, the Intranet Location uses the value set in Tools > Options.

Comments