Generate Process Hierarchy

A process hierarchy is a vertical hierarchy of processes, where a process corresponds to a Node in a Process Navigator map. The purpose of producing a process hierarchy is to show the integrated process model.

In the figure below, the process hierarchy shows ‘Top Level Recruitment Process’ as the top-level map that drills down to ‘The recruitment process’. ‘The recruitment process’ subsequently drills-down to the three maps: ‘Initiate recruitment’, ‘Drafting the shortlist’ and ‘Selecting the candidate’.

 
‘Initiate recruitment’ and ‘Drafting the shortlist’ then show the Activities held within these process maps and any subsequent drill-downs.

 
The process hierarchy shows the Activities within ‘Selecting the candidate’.  In addition, any subsequent drill-downs and documents that are linked from the process maps are visible as shown below.

 
Each of the process shapes will hyperlink to the page within the VDX map that contains its associated Node.  Processes on the same level conceptually are depicted on the same level visually and the page is re-sized to accommodate all shapes.

To create a process hierarchy, select all the maps in the Map Control Console that you want to include in the hierarchy.

Select Multi-Map > Generate Process Hierarchy or use the Generate Process Hierarchy button located on the toolbar.

You will then be prompted to specify the target .vdx file. Type in a name and select and click Save.

Visio will load and create the process hierarchy diagram. Once created, select File > Save.

Process Hierarchy Stencil

When a process hierarchy is generated, Microsoft Visio will load with a Process Hierarchy stencil which contains a Process shape, a Dynamic connector and a Link to Document shape as shown below.
 

SHAPE DEFINITION
Process Shape used to identify a process map. The Process shape name should coincide with the associated Node name of the map.
Dynamic Connector Connector that automatically routes between the shapes it connects using a right-angled line.
Link to Document Shape used to identify a document linked from an Activity within a process map.
 
You can add more shapes to your process hierarchy diagram and connect them with the Dynamic connector. Hyperlinks to process maps and external documents can be added to the shapes.

Showing Layers of Process Hierarchy

The process hierarchy, by default, will show all levels within the Multi-Map. The process hierarchy diagram is made up of the following layers: Node, Activity, Link to Document, Connectors. If you would prefer only to see the Node layers for the use of map organisation for example, you can turn off the visibility of the Activity and Link to Document layers.

To turn off the visibility of the Link to Document and Activity layers, within Microsoft Visio go to View > Layer Properties.

The following dialog box will appear:


In the Visible column, deselect Link to Document as shown below. This will show only the high level processes based on the Node and Activity names within the process maps.

In the figure below, the Link to Document visibility has been deselected. In the process hierarchy example, notice how the one document linked to ‘Hold interviews’ is no longer visible in the process hierarchy.

Under the Visible column, deselect Activity and this will show only the high level processes based on the Node names within the process maps.

If the Activity visibility is deselected then the lower level Activities within the process hierarchy are no longer visible and only the Nodes are shown as seen in the figure below.


To add back the visibility of the Activity and Link to Document layers, simply go to View > Property Layers and tick the box in the Visible column in the Layer Properties dialog box as shown above.

Publishing the Process Hierarchy to HTML
You can publish the process hierarchy to HTML through the Export to HTML Wizard.

TIP: Remember that when you publish to HTML, the published version will contain only the layers that you have selected to be visible.

Comments