File Does Not Contain Valid XML

 This article is suitable for an IT Adminstrator

Ref 20080611
Last Edited: January 17th 2012
 
Symptoms:  
 
When trying to open a process map in Process Navigator, you receive an error message saying 'File does not contain valid xml'.
 
Possible Causes
 
1. The file may be incomplete and unrepairable. This is caused because the file save operation is interrupted and the file is therefore truncated. Any of the following can cause the problem during a file save:
  • network trouble
  • a power fault
  • a server failure during the save
  • a failure on the client PC during
Publishing the Triaster Process Library requires Visio files to be loaded, processed, saved to HTML and saved to the disk. Therefore, if any of the above problems occurs at any stage during the Publish process, it may cause this problem.
 
2. Files may be used by Visio 2003 and Visio 2007 users whereby their Visio versions are not fully patched.
 
Solutions
 
1. You will need to revert to a back up copy of this file.
 
If this is a recurring problem, we suggest that you work on a copy of the process maps stored on the local hard drive. Once the edits are complete, copy the files up to the network using Windows Explorer. Also, the Save operation is entirely a Microsoft Visio process, i.e., Triaster have no control over this problem and can neither prevent it nor mitigate the likelihood of it. Therefore, please ensure you always have the latest version of the Visio software and service packs. Our understanding is that the Save operation in Visio 2007 works in a different way to previous versions, and is much less likely to cause the problem to occur. Therefore, if the problem is persistent, an upgrade to Visio 2007 may solve the problem. For more information please see Microsoft's Website.
 
2. We were able to reproduce the error using Visio version 2003 (11.3216.5606) and were able to rectify it by applying Service Pack 1 to Visio. However, we would recommend fully-patching Visio 2003; SP3 and possibly further updates are now available. Alternatively, upgrade all users to Visio 2007. We would also recommend patching Visio 2007; SP3 is available. We use fully-patched versions here.
 
This article can help to identify the version of Microsoft Office 2003 products, including Visio:
 
 
Applies to:
  • Process Navigator all versions
  • Visio 2003
  • Visio 2007

Need further help? Contact the Triaster Support team by e-mailing support@triaster.co.uk or by calling us on + 44 (0)870 402 1234.
 
Do you have any feedback or suggestions that you would like to share with Triaster? We would love to hear from you! Please e-mail feedback@triaster.co.uk